Issue
An admin would like to edit the data in the Output Table of a Workflow Task that is in a Terminal (completed, failed, or cancelled) status, but they are receiving the following error message: "Unable to edit [task name]: you are only authorized to edit outputs of in-progress tasks. If the edit was intentional, consult and admin to perform this update for you, or archive the task and recreate it."
Environment
Workflows, Permissions
Cause
Access Policies must be adjusted.
Resolution steps
Instructions for customer admin:
Go to your Avatar at the bottom left corner of your screen. Go to Feature Settings --> Access Policies --> General Access Policies --> Admin (or any other role access policy you'd like to edit). Scroll down to Workflow Tasks and then grant edit permissions as desired!
Once you change the access policies, you and other users with the applicable role should be able to edit Workflows data after the task is in a terminal status.