How do I revert the status of a task from 'cancelled,' 'failed,' or 'completed'?

Sewon
Sewon
  • Updated

Issue

Task is accidentally marked as 'cancelled' / 'failed' / 'completed' when it's not and the action needs to be undone.

 

Environment

Workflows Execution

 

Cause

Unfortunately, when a task has been marked as 'cancelled' / 'failed' / 'completed', its status can no longer be changed. 'Cancelled' / 'failed' / 'completed' is a “terminal status”, meaning the task has been executed and we don’t expect users to touch them anymore.

 

Resolution steps

Copy the task and re-execute the newly copied tasks. If you right click on the row with the task and select create new task from this row, this may make the copy and paste procedure a little easier.

 

This workaround, unfortunately, will not work for "Failed" tasks. Currently, updating a task to “Failed” will also update its flowchart task to “Failed” when there are no other pending tasks (so you will see an error message "Cannot clone XXX because it is part of a terminal flowchart"). With "Failed" workflow tasks, you would have to make them again manually instead of cloning them.

Was this article helpful?

Have more questions? Submit a request