Issue:
I want to pull data recorded in a Custom Field on an Entity or Entry via Insights.
Environment:
Insights
Cause:
Custom Fields data is not available in Insights. This is a brief explanation of why this is the case:
Insights can only pull data from the Data Warehouse.
The Data Warehouse is a collection of data tables. For Entities and Entries, there's one data table per Entity/Entry Schema. This data table contains one column for each field on the Schema, and one row for each item (entity or entry) of that schema. Data in this format (each value is associated with one schema field and one entity/entry) is considered 'structured data' in Benchling.
Any data in Benchling that is not in this format is considered 'unstructured data', and can't be made to fit into the structure of the Data Warehouse, so it's stored in a different type of database designed for unstructured data.
Since Custom Field data is not stored in a Schema field, it is not structured data and cannot be stored in the Data Warehouse, so it cannot be accessed by Insights.
Resolution Steps:
Option 1: Put Custom Field Data into the Data Warehouse by creating and filling Schema Fields
Steps:
1. Go to the Entity/Entry Schema (if you do not have an Entry Schema, you will need to create an Entry Schema).
2. Create the appropriate metadata field(s) to store the data from your Custom Fields. Ensure that the data type (text, integer, entity link, etc.) matches that of your Custom Field. Be sure to save your changes to your new fields.
3. Fill your Custom Field data into your new Schema Field. You may want to use the global search export function and bulk update tools if you have a lot of data to transfer.
4. Once this data is in a Schema Field, you'll be able to view it in Insights!
Option 2: View this data outside of Insights.
Custom Field data is available in Global Search, and does appear in CSVs exported from Global Search.
1. Click the Global Search (magnifying glass) icon in the left ribbon. Click the '>' symbol to expand the Global Search pane.
2. Filter, if desired. You can filter to a certain Item Type using the 'Type' dropdown, if you're interested in items of a certain schema. You can also filter based on a Custom Field by selecting 'Filters' --> 'Add Filter', and then choosing 'Custom Field' and typing the name of the Custom Field. You can then choose to see items with a specific value in that field, items that have any value in that field, or items that have that Custom Field but have no value in that field.
3. Scroll right in the Global Search pane until you find the desired Custom Field column.