Issue
User cannot submit a workflow task because it is archived. User is unable to archive the workflow task despite having Admin access to the task. They received the error message: "Sorry you have insufficient permissions to access [workflow task name]".
Environment
Production tenant
Cause
In this case, the Workflow Task could not be Unarchived because the Task Group was Archived. Individual tasks under an Archived Task Group cannot be Unarchived. The Task Group must be Unarchived first.
Another potential cause could be that the item was Archived by a different user and the Access Policy applied to the current user for this item does not allow Archiving and Unarchiving.
Resolution
Check to see if the Task Group that the Task belongs to is Archived: Navigate to the Workflow Task's Task Group. If the Task Group is Archived, the user will need to Unarchive the Task Group. Then, they can go back to the Task and Unarchive.
If this does not allow the user to Unarchive the Task, check Access Policies: Check the user's level of access to the Task (Write, Admin, etc.), and then view the Access Policy for this level of access. Ensure that the Archive dropdown in the Workflows section is set to Granted. If this is not granted, the user must ask their Admin to Unarchive the Task Group for them or to change their Access Policy or access level to the item.