Why can't I see the metadata field I'm looking for in entity$raw?

Ari
Ari
  • Updated

Issue

I want to use Insights to view a metadata field on my entity/entry, but the field I'm looking for isn't there.

Environment

Insights, Registry

Cause

Two common causes are:

1. User is searching in the entity$raw or entry$raw table instead of the table specific to the entity schema or entry schema. For example, if a user at the iheartmicrobes organization is interested in the 'species' field on the 'bacteria' schema, they'll need to query the table iheartmicrobes.bacteria (or iheartmicrobes.bacteria$raw, not the table iheartmicrobes.entity$raw.

 

2. The metadata field is a custom field. Custom fields are not stored in the warehouse, and so they cannot be queried in Insights.

Resolution steps

Enablement:

1. The user must use the entity-specific table in their query. Feel free to use the above example or generate your own.

or

2. Custom fields are not stored in the warehouse (only fields on the schema are stored in the warehouse), therefore can not be parsed within the query. If a user wants a field stored in the warehouse, they will need to get it added to the schema. If the item has no schema (may happen with entries), they will need to have a schema created and have the custom fields added to the schema as schema fields.

Additionally, custom fields can be seen in Global Search. If the user can't or doesn't want to make custom fields into schema fields, they may be able to find the answers they're looking for via Global Search Custom Fields Filter.

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