Troubleshooting SSO errors

Shruti
Shruti
  • Updated

When setting up SSO ensure the following steps have been completed:

  • SSO has been turned on for your organisation - this must be requested by your implementation manager. A quick way to check this is to look at the "invite users" button in manage team, if this is inactive and cannot be clicked then SSO is on, if you can still use this button to invite users by email, The ability to integrate with SSO has not yet been turned on for your organisation. Please contact your implementation manager to have this enabled.

  • The toggle to enable either Azure or Okta is on (blue) .

  • Application/Client ID, domain (Okta) and tenant IDs are correctly copied from the Application overview into the Benchling In Vivo SSO setup form.

  • The client secret is correct (in Azure this is known as the secret value)

  • The Benchling In Vivo settings have been saved.

  • Users have been granted access to the application in SSO.

 

 

Most common issues/errors with MS active directory (Azure):

Error Message

Cause

Resolution

Error AADSTS50011: The redirect URI specified in the request does not match

There is an issue with the URL entered in Azure application settings.

 

Error 500

Incorrect Secret value

In the certificates and secrets section of the application settings in Azure, create a new secret making sure to copy the Secret VALUE and paste this into the secret field In the Benchling In Vivo SSO setup page.

AADSTS50105: Your administrator has configured the application x to block users unless they are specifically granted ('assigned') access to the application

User has not been granted access to this application

Ensure that the user attempting to gain access to the application has bee added as a user or to the group of users assigned to this app in Azure.

 

Most common issues/errors with Okta:

Error

Resolution

Users cannot gain access

Ensure that the user attempting to gain access to the application has bee added as a user or to the group of users assigned to the enterprise application.

The page does not exist

Check the URIs for Login and logout. Ensure that you have entered the correct URI for sandbox or production depending on which environment this tenant is on.

See Setup guide for more information.

If you cannot resolve the issues you have or are hitting any error messages that direct you to contact support, don't hesitate to get in touch through your benchling representative or submit a ticket through in-app chat or support@benchling.com

Was this article helpful?

Have more questions? Submit a request