Issue
Password reset emails aren't being delivered to my inbox.
Environment
All versions and systems
Cause
The email was routed to your spam or junk folder. You have not checked your email spam/junk folder or used benchling.com/forgot to reset your password. That link is only for Academic customers.
Resolution steps
If the email was not in your spam or junk folders, send yourself a password reset email by going to: https://yourtenant.benchling.com/forgot where yourtenant is your tenant name.
If you're an Academic customer, please reset your password by going to benchling.com/forgot.
Please refer to this help article about reseting or recovering your password for more information.