How is Benchling changing its support for browser versions?

We are updating the range of browser versions Benchling is supported on in an effort to improve engineering velocity. The current supported browser versions can be found in this help article. For the best experience, we recommend using a supported browser.

What does this mean for me, as a customer?

At this time, you will still be able to use Benchling on an outdated browser version, but we expect older browsers to experience potential performance degradation. Customers using newly unsupported browser versions will see an error message. For the best user experience, we recommend using a supported browser.

See below for the list of browser versions on which we expect this degradation to occur:

  • Chrome 58 (Jan 2017)

  • Edge 14 (Aug 2016)

  • Firefox 54 (Mar 2017)

  • Safari 10 (Jul 2016)

  • Opera 55 (Aug 2018)

Did this answer your question?